RAM Steel - Report Viewer error

 Applies To 
 Product(s):RAM Structural System; Ram Steel Beam
 Version(s): and later
 Environment: Windows 7, Windows 10
 Area: General; Installation; Reports
 Original Author:Bentley Technical Support Group

Error Description

Case 1 - When running the framing tables in the Steel Beam module the warning, "Report Viewer Control has not been registered on this computer" may appear:

Case 2 - When trying to generate any report the same error can occur. 


Case 1 - This error typically happens when the user switches to another application (e.g. Microsoft Outlook) while the steel beam framing tables and/or design is being performed. To reproduce the problem, open RAM Steel beam and click the option to design all after framing. Then switch to another application while the framing tables are running.

Case 2 - This happens due to an incomplete installation or a problem with the Microsoft components that the Report Generator depends upon. The error can also happen if the report viewer control is registered in the wrong location.


Case 1 - If the operating system focus remains on RAM Steel beam during this process the error will not occur. The user has to click OK to the message to proceed. 

Case 2- The error can also happen if the report viewer control is registered in the wrong location,

To manually re-register the report viewer control, follow these steps.

1. Locate the file VPECTRL3.ocx, it is most likely here:

C:\Program Files (x86)\Common Files\Bentley\Engineering\VPEControl\VPECTRL.OCX

2. Go to the Windows Start button or pearl any type "run" without the quotes and hit enter

3. On the command prompt that appear type

regsvr32 "C:\Program Files (x86)\Common Files\Bentley\Engineering\VPEControl\VPECTRL3.OCX"

or change the path if the file is in another location

4. you should get a message that the registration succeeded.

Note, if more than one copy of the file is located first unregister all other copies using a similar command but with /u after regsvr32, before registering the good copy like so:

regsvr32 /u "C:\Path to other copy\VPECTRL3.OCX"

In few cases clean installation also solved the problem.

It's worth noting that with RAM Structural System, only one version can be installed at a time. Users who try to install both the 32 and 64 bit versions might also encounter this (and other) problems.

In more recent cases (March 2019) we have seen problems that can be fixed with completion of the latest Windows 10 and Microsoft Visual C++ Redistributable Updates.