Auto save is not working

Applies To
Version(s):Connect Edition ( and up )
Environment: ALL
Area: STAAD.Pro Download/Installation/Security/Performance
Subarea:  Performance
Original Author:Sye Chakraborty, Bentley Technical Support Group


I am using the STAAD.Pro Connect Edition and tried to enable the autosave from within the Files > Tools > Open Backup manager. However after I close out of the dialog box, the Enable Auto Save check box keeps getting unchecked and autosave is not working. What could be causing this ?


The settings are stored within a file named StaadPro21.00.00.ini. The file is located within the following folder

C:\Users\<your user name >\AppData\Local\Bentley\Engineering\STAAD.Pro CONNECT Edition\Default

Looks like that file is not getting updated.


Please try the following

Close out of STAAD.Pro CE

Right click on the shortcut for STAAD.Pro CE and choose “Run As Administrator”

Once the software launches, open a model and follow the same procedure to make the change.

Close out of STAAD.Pro CE.

Launch STAAD.Pro CE again ( this time as you normally do)

Go back to the Open Backup Manager and see if the Enable Auto Save box is still checked.


If not, please check with your system administrator on whether there are any permission related issues on the file/folder mentioned above.