User gets a failed snapshot capture queue job with error "Failed to render to PDF"


Product 

  
 Applies To 
  
 Product(s):Assetwise ALIM
 Version(s):16.7.xx
 Environment: N/A
 Area: eB System Management Console
 Subarea: Snapshot Capture Queue
 Original Author:Dennis Chan, Bentley Product Advantage Team

Problem Description:

User gets a failed snapshot capture queue job in the eB System Management Console with one of the following errors:

  • Failed to render to PDF - Error : HTML render is blank.
  • Failed to render to PDF - Error : Unable to render HTML. Failed to configure MSHTML engine due to the registry value "Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Security_HKLM_only". Please refer to the "MSHtmlBootstrap" option for an alternative configuration method.
  • Unable to render HTML. Failed to configure MSHTML engine due to the registry value "Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Security_HKLM_only". Please refer to the "MSHtmlBootstrap" option for an alternative configuration method.

Cause:

The issue is likely a security policy preventing the automated change of certain IE11 internet options in the registry for the service user.

Solution:

  1. Run regedit on the ALIM app server
  2. locate and set the following two registry keys:
    1. HKLM\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Security_HKLM_only = 0
    2. HKLM\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\PreventIgnoreCertErrors = 0
  3. Save and close regedit 
  4. Run Internet Explorer
  5. Go to Internet Options
  6. Under the Advanced tab check the box which says "Allow active content to run in files on My Computer"

Workaround:

N/A