启动Foundation软件,弹出STAAD授权过期,导致无法进入软件。


【问题描述】

启动Foundation软件,弹出STAAD授权过期,导致无法进入软件。

软件的购买情况是:目前登录ConnectionClient的账号只有Foundation授权,没有STAAD授权。

【原因分析】

这是因为用户在之前使用Foundation软件的时候,在授权配置的地方选择了STAAD的授权,并且在左下角的地方取消勾选了显示授权配置对话框,这样就导致了下次直接进入Foundation软件的时候,程序判断该登录账号没有购买STAAD的授权,而授权配置对话框看不到,无法修改使用Foundation授权,所以出现了上面的报错。

【解决方案】

用购买STAAD授权的账号登录ConnectionClient,这样可以先进入Foundation,点开授权配置对话框,将授权类型改成Foundation,并且勾选上Show on startup(默认也是勾选的),点击OK后,关闭软件。

重新使用购买Foundation授权的账号登录ConenctionClient,这时再启动Foundation软件的时候就可以进入了。