Probleme beim Öffnen von CHM-Hilfedateien


 Produkt(e):MicroStation
 Version(en):08.11.09.908
 Umgebung:N\A
 Produktbereich:Dokumentation und Hilfe
 Produktunterbereich:N\A

Hintergrund

Manchmal treten beim Öffnen von Hilfedateien (im CHM-Format kompiliert), die mit Bentley-Anwendungen bereitgestellt werden, Probleme auf. Meistens sind diese Probleme mit der Benutzerumgebung verbunden und stellen keinen Fehler in der Hilfe selbst dar. In den untenstehenden Problemlösungsen sind die häufigsten Ursachen und dessen Lösungen aufgeführt.



1. CHM-Dateien können nicht von einem entfernten Standort im Netzwerk angezeigt werden.

Normalerweise wird die folgende Meldung angezeigt:


Ursache:

Das Windows-Sicherheitsupdate verhindert den Zugriff auf chm-Dateien über das Netzwerk aufgrund einer Schwachstelle, die die Ausführung von Remote-Code ermöglichen könnte.

Lösung:

  1. Der einfachste Weg, dieses Problem zu lösen, ist das Verschieben der chm-Datei auf das lokale Laufwerk. Möglicherweise wissen Sie jedoch nicht, dass Sie einen Netzwerkstandort verwenden, um ihn zu überprüfen: Klicken Sie mit der rechten Maustaste auf die Meldung "Navigation zur Webseite wurde abgebrochen" oder irgendwo im Hilfe-Leserfenster, klicken Sie auf Eigenschaften und schauen Sie sich das Feld "Adresse" an.  Achten Sie auf den Pfad nach der Phrase "mk:@MSITStore:". Wenn es mit doppeltem Schrägstrich beginnt, dann verwenden Sie ein Netzwerklaufwerk.
  2. Wenn Sie ein Netzlaufwerk verwenden müssen, um chm-Dateien zu speichern, dann lesen Sie bitte folgende Microsoft-Empfehlungen, um es zu aktivieren: http://support.microsoft.com/kb/896054

2. Das Öffnen der Hilfe aus der Anwendung oder direkt von der Festplatte zeigt eine Fehlermeldung an.

Die Nachricht enthält Folgendes:

"Die Datei kann nicht geöffnet werden: mk:@MSITStore: C:\Programmdateien (x86)\Bentley\MicroStation V8i (SELECTseries)\MicroStation\readme_MicroStation.chm".

Ein Schlüssel in dieser Nachricht ist die Phrase "mk:@MSITStore". Diese Lösung ist möglicherweise nicht anwendbar, wenn Sie einen anderen Fehlertyp erhalten.

Ursache

Das Microsoft-Hilfesystem ist beschädigt. Normalerweise ist es schwierig, bestimmte Ursachen zu identifizieren, aber meistens liegt es an Drittinstallateuren, die entweder ältere Versionen von Hilfekomponenten bereitstellen oder diese nicht ordnungsgemäß registrieren.

Lösung:

  1. Öffnen Sie die Eingabeaufforderung als Administrator.
  2. Führen Sie die folgenden Befehle aus, um Hilfesystemkomponenten neu zu registrieren:
    regsvr32 %systemroot%\system32\hhhctrl.ocx
    regsvr32 %systemroot%\system32\itss.dll

3. Die Hilfe wird als XML anstelle von formatiertem Text angezeigt.

Ursache:

Dies wird durch falsche .htm- und.html-Dateitypinformationen in der Registry des Systems verursacht. Die HTML-Help-Komponenten von Microsoft gehen schief, wenn ein bestimmter Registrierungswert falsch gesetzt ist. Außerdem können Sie feststellen, dass nur einige chm-Dateien unkorrekt angezeigt werden, während andere Hilfedateien gut funktionieren. Es kann vorkommen, dass der Standardbrowser geändert wurde.
von Firefox/Chrome zum Internet Explorer oder umgekehrt.

Lösung:

  1. Öffnen Sie regedit und nehmen Sie die folgenden Änderungen vor:
  2. Navigieren Sie zu HKEY_LOCAL_MACHINE\Software\Classes\.htm und HKEY_LOCAL_MACHINE\Software\Classes\.html

    Stellen Sie sicher, dass es einen Schlüssel "Content Type" (Zeichenkettentyp) mit den Daten "text/html" gibt.
    Stellen Sie sicher, dass es einen Schlüssel "PerceivedType" (Zeichenkettentyp) mit Daten "text" gibt.
  3. Überprüfen Sie den Ordner HKEY_CURRENT_USER\Software\Classes\.htm und HKEY_CURRENT_USER\Software\Classes\.html.

    Wenn Sie diese Ordner nicht finden, dann tun Sie nichts. Andernfalls:
    Stellen Sie sicher, dass es einen Schlüssel "Content Type" (Zeichenkettentyp) mit den Daten "text/html" gibt.
    Stellen Sie sicher, dass es einen Schlüssel "PerceivedType" (Zeichenkettentyp) mit data= "text" gibt.

Sehen Sie hierzu auch

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Anderssprachige Quellen

English