「接続失敗」と表示される。


Connection failed

【原因】

最近の Microsoft WebView2 更新プログラム (v139.0.3405.86) で STS トークン形式が変更され、
古いバージョンの CONNECTION クライアント (v23.x 以下) が認証に失敗する原因となりました。
CONNECTION Client v24.01.00.23 以降にアップグレードすると、新しい認証プロトコルを使用して問題が解決されます。

【解決策】

CONNECTION Clientの最新版をインストールしお試し頂けますでしょうか。
https://www.bentley.com/software/connection-client/

 

【その他の現象】

CONNECTION Client サインインに失敗、または「接続の問題」と表示される。

  1. 以下のいずれかのエラーが表示されます。
    "The webpage cannot be displayed..."
    "Connection Issues. Could not connect..."


【解決策】

    1. 一時的な問題で再度サインインしてみてください。
      最初の確認として、CONNECTION Client ダイアログの中央を右クリックして「戻る」を選択して、またはF5をクリックして再サインインします。または、タスクトレイ(隠れアイコン)よりCONNECTION Clientアイコンを表示し、右クリックして「終了(X)」を押してから、ディスクトップアイコンまたはスタートメニューよりCONNECTION Clientを再起動します。

    2. CONNECTION Clientのバージョンを最新にします。
      CONNECTION Clientのバージョンを最新にアップグレードすると、問題は解決される場合があります。
      CONNECTION Client ダウンロードサイト

    3. システムクロック
      お使いのPCのシステムタイムを確認します。
      日本の現地時間にあっているかチェックします。
      わずかな時間 (5分)でも合っていなければ、CONNECTION Clientにサインインすることはできません。
      合っていない場合、現地時間に調整してCONNECTION Client にサインインできるか確認します。
      本現象の場合、ログを確認すると次のような行があります。
      ERROR - SingleSignOnControl - An error occurred during federated login process - IDXXXX: The SamlSecurityToken is rejected because the SamlAssertion.NotBefore condition is not satisfied.
      NotBefore: '3/1/2017 2:42:17 PM'
      Current time: '3/1/2017 2:31:58 PM'
      Bentley.Connect.Client.exe.logは下記場所に確認できます。
      C:\Users\ウィンドウスユーザー名\AppData\Local\Bentley\Logs\

    4. プロキシサーバとファイアウォール
      もう一つの原因は御社のネットワーク環境には
      プロキシサーバーもしくはファイアウォールより弊社サーバーへの通信をブロックしていると考えられます。
      本現象の場合、ログを確認すると次のように類似な行があります。
      02-07-17 07:17:17.931 [1] ERROR - SingleSignOnControl - An error occured during federated login process - The remote server returned an error: (407) Proxy Authentication Required.
      プロキシサーバーをご利用の場合は、下記のリンク先の内容に従って、
      プロキシの設定情報は全て設定されているかごチェックください。

  1. 「処理しています・・・」(Working...)の状態のまま、その先に進みません。「ページの有効期限切れ」にも変わりません。

    IEより、インターネットオプションを選択し、信頼済みサイトに「https://*.bentley.com」を追加します。

    上記インターネットオプション>詳細設定タブにて、以下のTLS( データを暗号化し安全にやり取りを行う )を有効にします。

    タスクマネージャーでBentley.Licensing.ServiceとBentley.Connection.Clientのプロセスがあれば、終了します。

    CONNECTION Clientを再起動してください。

アンチウイルスソフトウェア
場合によりウイルス対策ソフトウェアがCONNECTION Clientへの接続をブロックする場合があります。アプリケーションとトラフィックをウイルス対策ソフトウェアのルールに追加し回避しててください。