Verbindungsfehler - Verbindung konnte nicht hergestellt werden - Interoperabilitätsfehler


Problem

Beim Start des CONNECTION Client erscheint die Meldung "Connection Failure - Could not connect"

Mögliche Ursache #1

Konfiguration der Proxy-Server-Einstellungen

Lösung

Öffnen Sie das Bentley Licensing Tool und klicken Sie auf Extras > Optionen - Wenn Ihr Unternehmen keine Proxyserver-Einstellung benötigt, sollte diese leer gelassen werden.

Mögliche Ursache #2

Wenn Sie den folgenden Fehler in den Protokollen sehen, der besagt, dass entweder der Computer oder das Benutzerkonto nicht vertrauenswürdig sind oder keine Delegation zulassen:

ERROR - Manager - Failed to get WSG token: System.Security.Cryptography.CryptographicException: The requested operation cannot be completed. The computer must be trusted for delegation and the current user account must be configured to allow delegation.

Lösung

Anweisungen zum Aktivieren der Vertrauenswürdigkeit von Computer- und Benutzerkonten für die Delegation sind hier.

Bei der Windows-Datenschutz-API, die zum sicheren Speichern des Tokens eines Benutzers verwendet wird, treten Verbindungsprobleme mit dem Domänencontroller auf. Die folgenden Fehlerbehebungsschritte von Microsoft können helfen troubleshooting steps. Die dritte Lösung behebt das Problem in der Regel, aber die ersten beiden sollten Sie trotzdem ausprobieren. Wenn das Problem weiterhin besteht, beachten Sie bitte die folgenden alternativen Anweisungen 

Bitte starten Sie das System neu, nachdem Sie Änderungen vorgenommen haben.

Mögliche Ursache #3

Der folgende Fehler zeigt an, dass der Benutzer das ISRG Root X1-Sicherheitszertifikat nicht installiert hat:

ERROR - BUDDIClient - GetUrl() encountered an error: System.ServiceModel.Security.SecurityNegotiationException: Could not establish trust relationship for the SSL/TLS secure channel with authority 'buddi.bentley.com'. ---> System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.

Erklärung

Mehrere Bentley-Server verwenden ein von Let's Encrypt signiertes Sicherheitszertifikat. Let's Encrypt-Zertifikate werden von R3 signiert, das wiederum von ISRG Root X1 signiert wird, wie in der folgenden Erklärung von Let's Encrypt beschrieben explanation from Let's Encrypt. Wenn ISRG Root X1 nicht vertrauenswürdig ist, werden auch einige unserer Sicherheitszertifikate nicht vertrauenswürdig sein. Es folgt eine Erklärung für den Übergang zu ISRG Root, da Let's Encrypt zuvor von einer anderen Stammzertifizierungsstelle signiert wurde Erklärung für den Übergang zu ISRG Root.

Lösung

Lassen Sie Ihre IT-Abteilung bestätigen, dass ISRG Root X1 in der Liste der vertrauenswürdigen Zertifizierungen im Zertifikats-Snap-In für die Microsoft Management Console aufgeführt ist.

HINWEIS:

Wir stellen das Zertifikat nicht zur Verfügung, und wenn es fehlt, muss Ihre interne IT-Abteilung es von der Zertifizierungsstelle erhalten - navigieren Sie zum CONNECT Center, klicken Sie auf das Vorhängeschloss-Symbol links neben der URL, wählen Sie "Verbindung ist sicher" und klicken Sie auf die Zertifikatsinformationen/Symbol - die Zertifikatsdetails werden angezeigt, klicken Sie auf die Schaltfläche "Issuer Statement", die Sie zur Let's Encrypt-Zertifizierungsstelle weiterleitet


Siehe auch

Script Fehler bei Anmeldung mit 'Promise' - undefiniert oder Verbindungsfehler

Wie man Logdateien sammelt und übermittelt - Error Logging - Logs

Anderssprachige Quellen

Englisch

Polski