E512-65: the model cannot be opened ・・・


 プロダクト:AutoPIPE
 バージョン:CONNECT Edition

問題

以下のようなエラーメッセージが出たときの対処法を教えて下さい。

E512-65: the model cannot be opened as temporary directory cannot be set

E512-65: The model cannot be opened as cannot be copied to the temporary directory Possible reasons could be: Network connection failure No space in Temporary directory

E512-65: The model cannot be opened as it is temporarily locked for editing by:

E512-65 the model cannot be opened for editing:

解決策:

このエラーは以下のいずれかの原因によるものです。

原因1:

AutoPIPEプログラムは、ASCII文字セットのモデルパス名のみを扱うことができ、モデルパス内の2バイトUnicode文字や漢字はサポートしません。

以前のバージョンのAutoPIPEでは、モデルパスにASCII以外の文字が含まれていてもモデルを開くことができましたが、プログラムが不安定であるとの報告が多く寄せられました。一貫性チェック、解析、レポート作成などのコマンドを実行すると、すぐにアプリケーションがクラッシュしてしまうのです。

そのため、AutoPIPE V8i 09.02.xx.xx 以降では、このようなモデルを開くとブロックされ、上記のようなエラーメッセージ(例:E512-65...)が表示されるようになりました。

回避策:

ファイルパス名にASCII文字のみを使用

原因2:

ファイルサーバーのパーミッションに問題がある可能性があります。

回避策:

ユーザーは、自分のコンピュータの管理者/パワーユーザー権限を持っている必要があります。

  1. AutoPIPEユーザーに、バージョン別のフォルダの読み取り/書き込み権限があることを確認します。
  2. 該当フォルダーに対して 'Everyone' グループにフルアクセス権を付与

また、アプリケーションは管理者権限で実行します。アプリケーションを常に管理者として実行するようにマークするには、次のようにします。

  1. デスクトップに変更したいプログラムのショートカットを作成
  2. アプリケーションのショートカットを右クリックし、[プロパティ]をクリック
  3. 「プロパティ」ダイアログボックスで、「互換性」タブをクリック
  4.  次のいずれかを実行
    現在ログオンしているユーザーにこの設定を適用するには、[このプログラムを管理者として実行する]チェックボックスを選択し、[OK]をクリックします。
    アプリケーションの起動に使用するショートカットに関係なく、コンピュータ上のすべてのユーザーに設定を適用するには、[Change Setting For All Users]をクリックしてアプリケーションの.exeファイルのプロパティダイアログボックスを表示し、[Run This Program As An Administrator]チェックボックスを選択し、[OK]を2回クリックします。

これで、アプリケーションは常に管理者権限を使用して実行されるようになります。標準アカウントを使用していてプロンプトが無効になっている場合、アプリケーションの実行に失敗することに留意してください。

ユーザーのパーミッションの確認:

以下の両方のフォルダーでテストを行います。

  1. %temp%フォルダ (C:\Usersusername\AppData\Local\Temp)
    フォルダを探し、開く。AP_???? (例:AP_090602, AP_100000, etc...) を見つけて開きます。
  2. C:\ProgramData\Bentley AutoPIPE CONNECT\Examples
    1. 上記のフォルダの場所を開いてください。
    2. このフォルダーに新しいフォルダーやドキュメントを作成してみてください。

ここで新しいフォルダやドキュメントを作成できますか?

Yes - AutoPIPEを実行し、問題が解決したか確認

No - ユーザーが正しい権限を持っていないため、先に進む前にユーザーの権限を更新してください。

原因3:

モデルを保存しているネットワークサーバーの動作速度が遅い。

症状:最初の2回はエラーメッセージが表示されるが、3回以上モデルを開くとエラーメッセージが表示されずに開くことを繰り返す。

回避策:

モデルをサーバーの場所からローカルのハードディスクに移動し、モデルで作業を行い、終了したら最終モデルをネットワークサーバーに戻す。

また、IT部門にネットワーク監視ツールの使用を依頼し、問題とその解決策をより良く理解するようにしてください。

原因4:

モデルへのパス名が長すぎる場合にも表示されることがあります。

回避策:

AutoPIPE 9.4以降では、ファイルパスが256文字より短いことを確認してください。
 

原因5:

アンチウイルス/マルウェアソフトウェアが、AutoPIPEファイルをスキャン対象から除外するように正しく設定されていない。

回避策:

アンチウィルスソフトをインストールしているユーザーは、このアプリケーションのスキャン機能から除外する作業ディレクトリのリストにAutoPIPEとProjectWiseを追加するようIT部門に要求
 

原因6:

ユーザーAがモデルを開いており、ユーザーBが同じモデルを開こうとしている場合。一度に1人のユーザーしか同一モデルにアクセスできません。

回避策: 

ユーザーAがモデルを閉じ、ユーザーBがモデルを開くようにしてください。

原因7:

アプリケーションが異常終了し、*.LCKファイルが残ってしまっている。

ユーザーAがファイル(例:WALKTHRU.DAT)を開くと、モデルと同じフォルダの場所に*.LCKファイル(例:WALKTHRU.LCK)が保存されます。ユーザーBがユーザーAと同じファイルを開こうとすると、プログラムはLCKが配置されていることを確認し、モデルを開くことができなくなり、ユーザーBに対して上記のエラーメッセージを表示します。

しかし、典型的なコマンドを使用してモデルを閉じなかった場合(プログラムのクラッシュ、アプリケーションのフリーズ、コンピュータの電源障害など)、*.LCK ファイルはまだ残っている可能性があり、手動で削除する必要があります。

回避策

  1. AutoPIPEを閉じる

  2. AutoPIPEモデルフォルダ内のすべての*.LCKファイルを手動で検索し削除

  3. 以下のフォルダを探査
    C:\ Users\ username\ AppData\ Local\ Temp\ AP_090***\

これらのフォルダ(例:AP_090602、AP_100100など)には、モデルへのアクセス時にAutoPIPEが使用するTempファイルのみが含まれているため、削除してください。プログラムコマンドを使用してモデルを閉じた後(保存など)、AutoPIPEは対応するサブフォルダを自動的に削除します。モデルが正しく閉じられないと、サブフォルダは意図したとおりに削除されません。

原因8: 

アプリケーションのスプラッシュ画面が表示されない場合は、以下のWIKIをご覧ください。

AutoPIPE crashes, Faulting module name: ntdll.dll

原因9: 

描画ファイルがAPCファイル内にない可能性があります。

  1. APCファイルのコピーをデスクトップの新しいフォルダーに保存します。
  2. 新しいフォルダの場所を開く
  3. ファイル名を *.APC から *.ZIP に変更します。
  4. Zipファイルを任意のアーカイブアプリケーションで開く。
  5. ファイル名 *.DAT を検索する

*.DATファイルはフォルダにありますか?

yes - このページ内の別の原因の可能性があります。

no - APCファイル内に*.DATファイルがあること。そうでない場合は、モデルを開くことができません。唯一の提案は、*.APCファイルを生成するために使用される元のモデルを開き、アーカイブファイルとして再度保存することです。ファイル名が上記の命名規則を満たしていることを確認してください(例:ASCII文字のみ、ファイル名の長さが256未満、ファイル名の途中に「.」が含まれていない、ファイル名の最後の文字が「.DAT」の前にスペースがない、等々)。

 Original Author:Yasushi Nagao