Unrecognized Format
Error: Revit_0004
Error Message: The input file format is unsupported. Most probably it's mapped to a wrong connector. If not, please try to reload the file from its original location
Issue:
- The connector assigned to this file does not recognize the file format.
Cause:
- Incorrect file format or version, input file could be corrupted.
Solution:
Please change the connection definition to use the correct connector for this file. If it's already done, please open the file in the original application and try to re-save and upload this file again - perhaps the file was corrupted during the initial transfer. If possible, please try to upgrade the file format to a recent one in a newer application version. Please check the following KB Supported File Formats - KB0098377 to verify that the file has been saved in a supported version of the Revit Connector.
Error: Revit_0038
Error Message: Input file is not a Revit file, but rather a ZIP archive.
Issue:
- The connector cannot process ZIP archives.
Cause:
- A ZIP archive was provided as the input file.
Solution:
- Note that if this Revit file was retrieved from Autodesk Construction Cloud, it may in fact be a zipped file that contains multiple Revit models even though the file extension is .rvt. This is described in the following article: https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/Why-a-RVT-model-is-sometimes-downloaded-as-ZIP-from-BIM-360.html There are a couple of ways to check to see if this is the case once the file has been downloaded to your local disk.
- Open this .rvt file with a zipping program such as 7-zip and if you see that the file contains .rvt file(s).
- Try to open the .rvt file from your local disk with Revit, if it is a zipped file containing .rvt files, it will fail to open in Revit.
- If you have a zipped file with one or more Revit models, unzip the Revit files and use these for your iModel connection.