11. When importing a PCf file into AutoPIPE, Status = "Incorrect Component Connection Tolerance Valu

Applies To
Environment: N/A
Area: Import
Original Author:Bentley Technical Support Group
Date Logged
& Current Version
April. 2015


The following Appears in the Status window of the AutoPIPE PCF translator when importing a file:

Conversion Started...

Incorrect component connection tolerance Value


Conversion Aborted..


Conversion Started...

Incorrect component connection tolerance value

Incorrect component acceptable OD valve


Conversion Aborted..

Why does this occur and how to avoid it?


Solution #1:

Confirm that the "Map file" path name is specified, as shown in image #1 above. If the path name is blank, as shown in image #2 above, the conversion will abort every time because it cannot read the PCFIN.MAP file.

Again, specify the PCFIN.MAP path if it MAP FIle field was found to be blank.

Solution #2:

The problem is that the program is not able to read the tolerance setting in the PCFIN.MAP file.

Close AutoPIPE.

The AutoPIPE PCF translator is trying to read the PCFIN.Map file typically found in the following file location:

C:\ Bentley\ AutoPIPE Translators\ PCF Translator\ pcfin.map

This file can be opened by any text editor (Ms WORD, Ultra Edit, notePad, etc..). Depending on program version and default file, there is a Tolerance Setting found on line 628 (again, subject to change), shown below:

If this setting was found to be 0.000, or other small vales, change this value to be as shown above (starting in column 24), 1.000000. and save the file.

If you are unable to save the file because of write protection, there may be a permissions issue where the user is not currently logged in with ADMIN rights to this folder. Remember the user needs to have complete Read / Write to the following folders and all sub-folders within:


C:\ Users\ username \ AppData\ Local\ Temp

Be sure that the user has the correct permissions and the value of this setting is as indicated above before continuing. With this file saved and the tolerance confirmed, try to import the PCF file again.

The fie should import without issue. 

Solution #3:

Perform the following:

1. Close all AutoPIPE dialog screens 

2. Close AutoPIPE program.

3. Select Start> All Programs> Bentley Engineering> AutoPIPE Translator> PCF Translator

4. When the PCF translator dialog appears perform the following:

a. Select the correct PCF file to import

b. Select the correct mapping file

c. Set Open file = AutoPIPE

d. Set Material and Component library as needed Press Convert button

e. Select Tools> Settings

i. Enter an tolerance value

ii. Enter an Ignore OD value

iii. Check all boxes ON (typically)

iv. Press OK

f. Press Convert button

The model should no be imported. 

If continue to have problems, log a Bentley Service request with zip file containing PCF file, screen shots, etc.. 

See Also

PCF Translator FAQ & troubleshooting

Bentley AutoPIPE