13. How to map a Line Number from a PCF file into AutoPIPE?

Applies To
Environment: N/A
Area: Import
Original Author:Bentley Technical Support Group
Date Logged
& Current Version
Sept. 2016


When importing a PCF file, how to map the line numbers so they appear in the program? 


Open the PCF translator, select Help> User Reference. Search the PDF for Line number. 

Under Section 3: Settings is a section on Line Class and Line Numbers.

By default:

Pipe Properties "Line class" data is mapped from the PCF PIPING-SPEC field

Segment "Line number" data is mapped from the PCF MISC-SPEC1 field

Note, There are 2 methods to adjust these mapping settings:

1. Modify the actual PCF file directly with text editing software

2. Using AutoPIPE - Tools> Setting> PCF CAD Mapping command

#1: Use Text Editing software:

Open the PCFIN.MAP file using any text editing software (NotePadd++, Ultra Edit, MS Word, etc..) and make changes to these mapping settings as needed.

#2: Use AutoPIPE command

With AutoPIPE open, select Tools> Settings> PCF CAD Mapping command. After the dialog appears, select the PCF attribute from the drop down listing to be used when mapping to AutoPIPE.

Question: What to do when the Line Number and or Line Class is blank after importing a PCF file?


If either the "Pipe Properties Line class" or "Segment Line number are blank:

Means PCF file does not have legitimate data in the  fields as specified in the PCFIN.MAP file:


1. Confirm PCF file has legitimate data in the correct fields. Update original model used to create the PCF file and regenerate a corrected PCF file to be imported into AutoPIPE

2. Redefine the PCFIN.MAP file settings to remap LINECLASS and/or LINENUMBER, fields to the correct fields in the PCF file containing this data 

Example #1:

After importing PCF file into AutoPIPE, Segment Line number was found to be blank. Why?

After review, the PCFIN.MAP file had the default settings. However see the following section from the original PCF file, 


What is wrong with the PCF file?

(hint: look at the PCFIN.MAP file, what is the "Line Class" and "Line Number" mapped to?)


See image above, default PCF settings:

Line Class is mapped to PIPING-SPEC

Line number is mapped to MIS-SPEC1

See that the  MIS-SPEC1 attribute filed is completely missing from the original PCF file. Therefor the original program that created the PCF file did not export this data field or there was no data to be exported. Regardless, problem is with the original program that created the PCF file.

Solution #1:  Using the original software that created the PCF file, update model so MISC-SPEC1 attribute is exported to the PCF file

Solution #2:  User can manually update the PCF file with the proper data. Example: add line number "1234-ABCD" to a pipe in the PCF file:

Step #1, open the PCF in any word processing application (i.e NotePadd++, Ultra Edit, MS Word, etc..) 

Step #2: Add the missing line as shown above. 

Step #3: Save the newly updated file,

Step #4: using PCF translator convert the updated file and re-open the new model in AutoPIPE

Step #5: Review the input grid, Segment tab:

Step #6: Done...now, line number is correctly imported from PCF file

See Also

PCF Translator FAQ & troubleshooting

Bentley AutoPIPE