Following error "internal failure error 0x80040707" occurs when installing PLantFLOW


Applies To
Product(s):PlantFLOW
Version(s):V8i
Area: Install
Original Author:Bentley Technical Support Group
Date Logged
& Current Version
Dec 2014
06.02.00.05

Problem:

The following occurs when installing PlantFLOW:

Install Failure

Error Number: 0x80040707

Description: USER32.MessageBoxA:

Solution:

Cause:

This error may occur if there is a missing or invalid path in the registry.

Solution:

Try the following procedure:

1. Go to the directory that holds the file for launching the installation (for example,C:\BentleyDownloads\ program name\ Setup.exe).

2. Right-click on the installation file and select Properties.

3. A dialog will appear, select the Compatibility Tab, on this tab:

a. Place a check in the check box next to "Run this program in compatibility mode for : Windoes XP (service Pack3)

b. Place a check in the check box next to "Run this program as an administrator"

Press Apply Button and then press OK button to close dialog.

4. Be sure that All Background programs are closed and Temp folder is empty

5. Be sure that Virus Protection has be temporarily turned OFF.

6. Double click on Setup.exe to start installing the program.

If the error occurs again after using the procedure above, recommend the following:

1. Contact your IT department and request that your computer registry be cleaned and fixed. IT will use a special application to clean and fix the registry.  

Note: Please create a backup of your Windows Registry by highlighting “My Computer” and clicking “Registry > Export Registry File” or “File > Export”. Select a location and name to save the backup file to. 

2. After the registry has been cleaned and fix. Try the procedure above again. 

3. Contact Bentley if you continue to have installation problems.

See Also

Bentley AutoPIPE